biniyam20
194
7
Forge

Forge is not running my migrations in my deploy script

Posted 5 months ago by biniyam20

When I push to deploy via github webhook or click the deploy now button on Forge, Forge does not refresh and seed my migrations, as I I have in my deploy script. Any tips to debug?

//deploy script
cd /home/forge/default
git pull origin laravel
composer install --no-interaction --prefer-dist --optimize-autoloader
echo "" | sudo -S service php7.2-fpm reload

if [ -f artisan ]
then
    php artisan migrate:fresh --seed
fi
//lastest deployment log
Thu Nov 29 20:50:29 UTC 2018
From github.com:biniyam17/NextDorm
 * branch            laravel    -> FETCH_HEAD
   724045b..c57435f  laravel    -> origin/laravel
Updating 724045b..c57435f
Fast-forward
 database/migrations/2018_11_29_072740_create_log_events_table.php | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
Nothing to install or update
Generating optimized autoload files
> Illuminate\Foundation\ComposerScripts::postAutoloadDump
> @php artisan package:discover --ansi
Discovered Package: beyondcode/laravel-dump-server
Discovered Package: fideloper/proxy
Discovered Package: laravel/tinker
Discovered Package: nesbot/carbon
Discovered Package: nunomaduro/collision
Package manifest generated successfully.
**************************************
*     Application In Production!     *
**************************************

Command Cancelled!

Please sign in or create an account to participate in this conversation.

Reply to

Use Markdown with GitHub-flavored code blocks.