Problem when importing css from Google in app.scss when running "npm run production"

Published 1 year ago by cedamorim

When I run "npm run dev", it works fine .. no problem. However, when I run "npm run production", this error appears and I do not know how to solve it.

Output error

              WARNING  Compiled with 1 warnings

 warning  in ./resources/assets/sass/app.scss

  resolve-url-loader cannot operate: CSS error
  F:\web\src\demo\resources\assets\sass\app.scss:2:458: missing '{'
  at error (F:\web\src\demo\node_modules\css\lib\parse\index.js:62:15)

 @ ./resources/assets/sass/app.scss 4:14-248
 @ multi ./resources/assets/js/app.js ./resources/assets/sass/app.scss
                                                                                                                                                                                                                                                                               Asset      Size  Chunks                    Chunk Names
       \js\app.js    284 kB       0  [emitted]  [big]  \js\app
     /css/app.css  86 bytes       0  [emitted]         \js\app
mix-manifest.json  70 bytes          [emitted]

WARNING in ./~/css-loader!./~/postcss-loader!./~/resolve-url-loader!./~/sass-loader?sourceMap&precision=8!./resources/assets/sass/app.scss
  resolve-url-loader cannot operate: CSS error
  F:\web\src\demo\resources\assets\sass\app.scss:2:458: missing '{'
  at error (F:\web\src\demo\node_modules\css\lib\parse\index.js:62:15)
 @ ./resources/assets/sass/app.scss 4:14-248
 @ multi ./resources/assets/js/app.js ./resources/assets/sass/app.scss

app.scss ( only this line )

// Fonts
@import url(https://fonts.googleapis.com/css?family=Roboto:300,400,500,700,400italic);

Versions:

laravel 5.4 npm 4.1.1 node v6.2.0

Best Answer (As Selected By cedamorim)
cedamorim

Do not worry, I already figured out what it was. For those who need it, I just put a body {background-color: #fff; } [Or something else] after @import has already resolved the error.

But I have no idea why this

cedamorim

Do not worry, I already figured out what it was. For those who need it, I just put a body {background-color: #fff; } [Or something else] after @import has already resolved the error.

But I have no idea why this

vladimir

I am having same problem, and adding body{} did not solve it. Still looking for solution

Please sign in or create an account to participate in this conversation.