fsdolphin
265
2
Mix

npm Error npm WARN deprecated [email protected]

Posted 2 years ago by fsdolphin

I'm trying to user Elixir in a bran new Laravel project but I keep getting an error when I run the npm install command.

    npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
    npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
    npm WARN deprecated [email protected]: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to [email protected]^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.
    npm WARN prefer global [email protected] should be installed with -g
    npm WARN prefer global [email protected] should be installed with -g
    > [email protected] install /var/www/mySite/node_modules/node-sass
    > node scripts/install.js
    Start downloading binary at https://github.com/sass/node-sass/releases/download/v3.10.1/linux-x64-46_binding.node
    Binary downloaded and installed at /var/www/mySite/node_modules/node-sass/vendor/linux-x64-46/binding.node
    > [email protected] postinstall /var/www/mySite/node_modules/node-sass
    > node scripts/build.js

    "/var/www/mySite/node_modules/node-sass/vendor/linux-x64-46/binding.node" exists. 
    testing binary.
    Binary is fine; exiting.
    /var/www/mySite

    ├── [email protected] 
    ├─┬ [email protected] 
    │ ├── [email protected] 
    │ ├─┬ [email protected] 
    │ │ ├── [email protected] 
    │ │ ├── [email protected] 
    │ │ ├─┬ [email protected] 
    │ │ │ └── [email protected] 
    │ │ ├── [email protected] 
    ... more garbage
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected]^1.0.0 (node_modules/chokidar/node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

Have any one seen this error before? Any idea how to solve it?

I tried ...

rm -rf node_modules/

npm cache clean

This is what I have installed.

npm -v // output 3.10.8

nodejs -v // output v4.6.1

Please sign in or create an account to participate in this conversation.

Reply to

Use Markdown with GitHub-flavored code blocks.