MidhunMonachan
1 week ago

Alpine JS Support for IE11 and legacy browsers

Posted 1 week ago by MidhunMonachan

Hi, I see in the alpine js docs that to enable ie11 and legacy browser support, I can use

<script type="module" src="https://cdn.jsdelivr.net/gh/alpinejs/[email protected]/dist/alpine.min.js"></script>
<script nomodule src="https://cdn.jsdelivr.net/gh/alpinejs/[email protected]/dist/alpine-ie11.min.js" defer></script>

I use alpine as a npm package. So I include this in my js :

import 'alpinejs';

The problem is that I can't find any information on how to include the alpine-ie11.js which is in my alpine node module directory along with alpine.js. Is there any possible way to include this alpine-ie11.js using an import statement.

My goal is to host it myself without a cdn. I know I can just copy that file over from the node modules directory, but I don't want to deal with it everytime there is a new update.

Thanks

Please sign in or create an account to participate in this conversation.