legnus

legnus

Member Since 3 Days Ago

Experience Points 150
Experience Level 1

4,850 experience to go until the next level!

In case you were wondering, you earn Laracasts experience when you:

  • Complete a lesson — 100pts
  • Create a forum thread — 50pts
  • Reply to a thread — 10pts
  • Leave a reply that is liked — 50pts
  • Receive a "Best Reply" award — 500pts
Lessons Completed 0
Lessons
Completed
Best Reply Awards 0
Best Reply
Awards
  • start-engines Created with Sketch.

    Start Your Engines

    Earned once you have completed your first Laracasts lesson.

  • first-thousand Created with Sketch.

    First Thousand

    Earned once you have earned your first 1000 experience points.

  • 1-year Created with Sketch.

    One Year Member

    Earned when you have been with Laracasts for 1 year.

  • 2-years Created with Sketch.

    Two Year Member

    Earned when you have been with Laracasts for 2 years.

  • 3-years Created with Sketch.

    Three Year Member

    Earned when you have been with Laracasts for 3 years.

  • 4-years Created with Sketch.

    Four Year Member

    Earned when you have been with Laracasts for 4 years.

  • 5-years Created with Sketch.

    Five Year Member

    Earned when you have been with Laracasts for 5 years.

  • school-session Created with Sketch.

    School In Session

    Earned when at least one Laracasts series has been fully completed.

  • welcome-newcomer Created with Sketch.

    Welcome To The Community

    Earned after your first post on the Laracasts forum.

  • full-time-student Created with Sketch.

    Full Time Learner

    Earned once 100 Laracasts lessons have been completed.

  • pay-it-forward Created with Sketch.

    Pay It Forward

    Earned once you receive your first "Best Reply" award on the Laracasts forum.

  • subscriber-token Created with Sketch.

    Subscriber

    Earned if you are a paying Laracasts subscriber.

  • lifer-token Created with Sketch.

    Lifer

    Earned if you have a lifetime subscription to Laracasts.

  • lara-evanghelist Created with Sketch.

    Laracasts Evangelist

    Earned if you share a link to Laracasts on social media. Please email [email protected] with your username and post URL to be awarded this badge.

  • chatty-cathy Created with Sketch.

    Chatty Cathy

    Earned once you have achieved 500 forum replies.

  • lara-veteran Created with Sketch.

    Laracasts Veteran

    Earned once your experience points passes 100,000.

  • 10k-strong Created with Sketch.

    Ten Thousand Strong

    Earned once your experience points hits 10,000.

  • lara-master Created with Sketch.

    Laracasts Master

    Earned once 1000 Laracasts lessons have been completed.

  • laracasts-tutor Created with Sketch.

    Laracasts Tutor

    Earned once your "Best Reply" award count is 100 or more.

  • laracasts-sensei Created with Sketch.

    Laracasts Sensei

    Earned once your experience points passes 1 million.

  • top-50 Created with Sketch.

    Top 50

    Earned once your experience points ranks in the top 50 of all Laracasts users.

14 Aug
3 days ago

legnus left a reply on Laravel, Composer And A Google Merchant Class With Error

The rows I have not published and above are just for collecting information from the database. This is ok, but when I call the class to generate the feed, it displays this error. It is not related to the lines I did not publish because I already tested. It is related to the class itself. It does not find, but was perfectly installed on the server via composer and confirmed.

legnus left a reply on Laravel, Composer And A Google Merchant Class With Error

Why "not found" if I'm calling the class here:

$feed = new \Vitalybaev\GoogleMerchant\Feed("Test", "https://mysite.com", "Destak");

legnus left a reply on Laravel, Composer And A Google Merchant Class With Error

I was trying ... now it's ok.

I don't know why this error is occurring at execution.

legnus started a new conversation Laravel, Composer And A Google Merchant Class With Error

Please, can you help me?

I installed the "vitalybaev/google-merchant-feed" class to generate a product feed from my site for Google Merchant and I am encountering the problem below. Does anyone know what is wrong with my code?

PHP Fatal error: Uncaught Error: Class 'Vitalybaev\GoogleMerchant\Feed' not found in /home/admin/web/mysite.com/public_html/cron/googleshopping.php:143 Stack trace: #0 {main} thrown in /home/admin/web/mysite.com/public_html/cron/googleshopping.php on line 143

My code:

$feed = new \Vitalybaev\GoogleMerchant\Feed("Test", "https://mysite.com", "Destak");

foreach ($products as $product) {

    $item = new \Vitalybaev\GoogleMerchant\Product();
    $item->setId($chave);
    $item->setTitle($titulo);
    $item->setDescription($descricao);
    $item->setLink($linkurl);
    $item->setImage($imagem);
    $item->setAvailability("Disponível");
    $item->setPrice("{$product->price} BRL");
    $item->setGoogleCategory($categoria);
    $item->setBrand($marca_name);
    $item->setCondition($condi);
    $item->setShipping($fretefinal);
    $feed->addProduct($item);

}

$feedXml = $feed->build();
13 Aug
4 days ago

legnus started a new conversation Lavarel + Composer And A Mistake I Don't Understand.

I am a beginner in laravel and would like to ask for your help. I installed the "statickidz / php-google-translate-free" class via "composer" and it worked, but only if I'm at the root of the project (index.php). If I try to use it in a subdirectory file it doesn't work, displaying the error: "syntax error, unexpected 'use' (T_USE) (View: / home / u5799060 / public_html / themes / default / views / frontend / supp / subheader.blade.php) "

The instruction is below, and must be inside the "subheader.blade.php" file but not work:

    require_once ('../vendor/autoload.php');
        use \Statickidz\GoogleTranslate;

        $source = 'bn';
        $target = 'en';
        $text = 'আমি করবো না।';

        $trans = new GoogleTranslate();
        $result = $trans->translate($source, $target, $text);

        echo '<h2>'.$result.'</h2>'

I've already tried:

require_once ('../../vendor/autoload.php'); require_once ('../../../vendor/autoload.php'); require_once ('../../../vendor/autoload.php'); . . . but not work. What's wrong?