dane5890

dane5890

Member Since 2 Years Ago

Experience Points 800
Experience Level 1

4,200 experience to go until the next level!

In case you were wondering, you earn Laracasts experience when you:

  • Complete a lesson — 100pts
  • Create a forum thread — 50pts
  • Reply to a thread — 10pts
  • Leave a reply that is liked — 50pts
  • Receive a "Best Reply" award — 500pts
Lessons Completed 0
Lessons
Completed
Best Reply Awards 0
Best Reply
Awards
  • Start Your Engines Achievement

    Start Your Engines

    Earned once you have completed your first Laracasts lesson.

  • First Thousand Achievement

    First Thousand

    Earned once you have earned your first 1000 experience points.

  • One Year Member Achievement

    One Year Member

    Earned when you have been with Laracasts for 1 year.

  • Two Year Member Achievement

    Two Year Member

    Earned when you have been with Laracasts for 2 years.

  • Three Year Member Achievement

    Three Year Member

    Earned when you have been with Laracasts for 3 years.

  • Four Year Member Achievement

    Four Year Member

    Earned when you have been with Laracasts for 4 years.

  • Five Year Member Achievement

    Five Year Member

    Earned when you have been with Laracasts for 5 years.

  • School In Session Achievement

    School In Session

    Earned when at least one Laracasts series has been fully completed.

  • Welcome To The Community Achievement

    Welcome To The Community

    Earned after your first post on the Laracasts forum.

  • Full Time Learner Achievement

    Full Time Learner

    Earned once 100 Laracasts lessons have been completed.

  • Pay It Forward Achievement

    Pay It Forward

    Earned once you receive your first "Best Reply" award on the Laracasts forum.

  • Subscriber Achievement

    Subscriber

    Earned if you are a paying Laracasts subscriber.

  • Lifer Achievement

    Lifer

    Earned if you have a lifetime subscription to Laracasts.

  • Laracasts Evangelist Achievement

    Laracasts Evangelist

    Earned if you share a link to Laracasts on social media. Please email [email protected] with your username and post URL to be awarded this badge.

  • Chatty Cathy Achievement

    Chatty Cathy

    Earned once you have achieved 500 forum replies.

  • Laracasts Veteran Achievement

    Laracasts Veteran

    Earned once your experience points passes 100,000.

  • Ten Thousand Strong Achievement

    Ten Thousand Strong

    Earned once your experience points hits 10,000.

  • Laracasts Master Achievement

    Laracasts Master

    Earned once 1000 Laracasts lessons have been completed.

  • Laracasts Tutor Achievement

    Laracasts Tutor

    Earned once your "Best Reply" award count is 100 or more.

  • Laracasts Sensei Achievement

    Laracasts Sensei

    Earned once your experience points passes 1 million.

  • Top 50 Achievement

    Top 50

    Earned once your experience points ranks in the top 50 of all Laracasts users.

01 Jun
2 weeks ago

dane5890 left a reply on Installing Two Laravel Apps On Same Server

@SNAPEY - yes. Both are enabled. I put the subdomain outside of the html folder, I wonder if that is it

dane5890 left a reply on Installing Two Laravel Apps On Same Server

@SNAPEY - I think you might be right when I tried to trace route of the subdomain I get this error

Temporary failure in name resolution Cannot handle "host" cmdline arg

I'll have to go back to the Godaddy records and see.

dane5890 left a reply on Installing Two Laravel Apps On Same Server

@EJDELMONICO - I checked the .env file and the APP_URL shows http://localhost, perhaps you are right. So I would need to change the APP_URL to http://subdomain.domain.com with subdomain being my preferred sub domain and .domain.com being my domain. Do I have that right?

What are the DNS tools that you can recommend

dane5890 started a new conversation Installing Two Laravel Apps On Same Server

Hey, another question. I have a vps server that is hosting a laravel app, which works fine. No problems. Now I want to add a subdomain with another laravel app, but it says site can't be reached. I created a virtualhost for the subdomain outside of the /var/www/html folder to avoid conflicts and set the subdomain up in Godaddy. Did I miss a step?

dane5890 left a reply on Installing October CMS Inside Laravel 5.6

I think you're right. When I try to install inside, I can't login to the back end.

dane5890 started a new conversation Installing October CMS Inside Laravel 5.6

Hi, I have an existing Laravel 5.6 app. I know want to install October CMS inside it? What's the best way to go about it?

26 Feb
3 months ago

dane5890 left a reply on Phpmailer With Laravel 5.6

@AZURINSPIRE - Didn't know it existed, But I have some third party plugins that rely on Phpmailer. So I'm still going to need it.

24 Feb
3 months ago

dane5890 started a new conversation Phpmailer With Laravel 5.6

Hi all, I've got a Laravel 5.6 app. How can I get phpmailer to work with it. The regular phpmailer install doesn't seem to work. Is there something special that I have to do?

Thanks

31 Dec
5 months ago

dane5890 left a reply on Laravel Migration Error When Trying To Migrate A New Package

Got it to work. I deleted the comments column in my sql file and it works like a charm

30 Dec
5 months ago

dane5890 started a new conversation Laravel Migration Error When Trying To Migrate A New Package

Hi all, I'm trying to install a laravel comment system package for my laravel 5.6 app. However when I execute php artisan migrate, I get this error...

Illuminate\Database\QueryException : SQLSTATE[42000]: Syntax error or access violation: 1166 Incorrect column name '' (SQL: alter table comments add `` int unsigned not null)

at /var/www/html/*/vendor/laravel/framework/src/Illuminate/Database/Connection.php:664 660| // If an exception occurs when attempting to run a query, we'll format the error 661| // message to include the bindings with SQL, which will make this exception a 662| // lot more helpful to the developer instead of just the database's errors. 663| catch (Exception $e) {

664| throw new QueryException( 665| $query, $this->prepareBindings($bindings), $e 666| ); 667| } 668|

Exception trace:

1 PDOException::("SQLSTATE[42000]: Syntax error or access violation: 1166 Incorrect column name ''") /var/www/html/*/vendor/laravel/framework/src/Illuminate/Database/Connection.php:458

2 PDOStatement::execute() /var/www/html/*/vendor/laravel/framework/src/Illuminate/Database/Connection.php:458

Please use the argument -v to see more details.

Does anyone know what's going on?

10 May
1 year ago

dane5890 started a new conversation Can't Mix Nor Npm Install For Laravel 5.5 After Upgrading To Ubuntu 18.04

Hi all, for a while I've been able to do npm installs and laravel 5.5 mixes easily on Ubuntu 17. But after upgrading to Ubuntu 18. I can no longer do neither. I purged my nodejs and npm as well as my node modules folder and installed to the latest versions thinking that it will solve it, but no dice. Every time I do an npm install, here is the error I get...

[email protected] install /var/www/html/ota/node_modules/node-sass node scripts/install.js

Unable to save binary /var/www/html/ota/node_modules/node-sass/vendor/linux-x64-64 : { Error: EACCES: permission denied, mkdir '/var/www/html/ota/node_modules/node-sass/vendor' at Object.fs.mkdirSync (fs.js:840:3) at sync (/var/www/html/ota/node_modules/mkdirp/index.js:71:13) at Function.sync (/var/www/html/ota/node_modules/mkdirp/index.js:77:24) at checkAndDownloadBinary (/var/www/html/ota/node_modules/node-sass/scripts/install.js:114:11) at Object. (/var/www/html/ota/node_modules/node-sass/scripts/install.js:157:1) at Module._compile (internal/modules/cjs/loader.js:678:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:689:10) at Module.load (internal/modules/cjs/loader.js:589:32) at tryModuleLoad (internal/modules/cjs/loader.js:528:12) at Function.Module._load (internal/modules/cjs/loader.js:520:3) errno: -13, syscall: 'mkdir', code: 'EACCES', path: '/var/www/html/ota/node_modules/node-sass/vendor' }

[email protected] postinstall /var/www/html/ota/node_modules/node-sass node scripts/build.js

Building: /usr/local/bin/node /var/www/html/ota/node_modules/node-gyp/bin/node-gyp.js rebuild --verbose --libsass_ext= --libsass_cflags= --libsass_ldflags= --libsass_library= gyp info it worked if it ends with ok gyp verb cli [ '/usr/local/bin/node', gyp verb cli '/var/www/html/ota/node_modules/node-gyp/bin/node-gyp.js', gyp verb cli 'rebuild', gyp verb cli '--verbose', gyp verb cli '--libsass_ext=', gyp verb cli '--libsass_cflags=', gyp verb cli '--libsass_ldflags=', gyp verb cli '--libsass_library=' ] gyp info using [email protected] gyp info using [email protected] | linux | x64 gyp verb command rebuild [] gyp verb command clean [] gyp verb clean removing "build" directory gyp verb command configure [] gyp verb check python checking for Python executable "python2" in the PATH gyp verb which succeeded python2 /usr/bin/python2 gyp verb check python version /usr/bin/python2 -c "import platform; print(platform.python_version());" returned: "2.7.15rc1\n" gyp verb get node dir no --target version specified, falling back to host node version: 10.0.0 gyp verb command install [ '10.0.0' ] gyp verb install input version string "10.0.0" gyp verb install installing version: 10.0.0 gyp verb install --ensure was passed, so won't reinstall if already installed gyp verb install version is already installed, need to check "installVersion" gyp verb got "installVersion" 9 gyp verb needs "installVersion" 9 gyp verb install version is good gyp verb get node dir target node version installed: 10.0.0 gyp verb build dir attempting to create "build" dir: /var/www/html/ota/node_modules/node-sass/build gyp ERR! configure error gyp ERR! stack Error: EACCES: permission denied, mkdir '/var/www/html/ota/node_modules/node-sass/build' gyp ERR! System Linux 4.15.0-20-generic gyp ERR! command "/usr/local/bin/node" "/var/www/html/ota/node_modules/node-gyp/bin/node-gyp.js" "rebuild" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library=" gyp ERR! cwd /var/www/html/ota/node_modules/node-sass gyp ERR! node -v v10.0.0 gyp ERR! node-gyp -v v3.6.2 gyp ERR! not ok Build failed with error code: 1 npm WARN [email protected] requires a peer of [email protected] || 2 || ^2.1.0-beta || ^2.2.0-rc but none is installed. You must install peer dependencies yourself. npm WARN vue-[email protected] requires a peer of [email protected]^1.2.0 but none is installed. You must install peer dependencies yourself. npm WARN [email protected] requires a peer of [email protected]^1.0.0 but none is installed. You must install peer dependencies yourself. npm WARN [email protected] requires a peer of [email protected]^1.0.0 but none is installed. You must install peer dependencies yourself. npm WARN [email protected] requires a peer of [email protected]^2.0.0 but none is installed. You must install peer dependencies yourself. npm WARN [email protected] requires a peer of [email protected]^4.3.0 || ^5.0.0 but none is installed. You must install peer dependencies yourself. npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! [email protected] postinstall: node scripts/build.js npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the [email protected] postinstall script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in: npm ERR! /home/dane5890/.npm/logs/2018-05-10T18_4207_534Z-debug.log

Can anyone help?

Thanks

07 Feb
1 year ago

dane5890 started a new conversation CORS Access Domain Issues With Laravel 5.5

Hi, just deployed my Laravel 5.5 app. I also set up apache solr 7.1 on an independent server for a search engine. But every time I use ajax on my laravel app to fetch data from the server, I keep getting this error

ailed to load http://165.227.51.148:8983/solr/: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'http://localhost:8000' is therefore not allowed access.

I tried installing middleware packages for Laravel as well as adding cors headers on the apache server and on my localhost for testing and I keep getting the same errors.

Can anyone help?

Thanks,

Dane

03 Feb
1 year ago

dane5890 started a new conversation Using Laravel 5.5 With Apache Solr 7.1

Hi, I've deployed my laravel 5.5 app. I'm also working on a server that is dedicated to Apache Solr 7.1. Is there a program or somewhere where I can fin instructions on pointing the search engine for laravel 5.5 to the Apache Solr 7.1 engine?

Thanks

Dane

23 Jan
1 year ago

dane5890 left a reply on Laravel 5.5 Not Routing On Live Server

Got it to work. I tweaked the apache2 conf file!

dane5890 started a new conversation Laravel 5.5 Not Routing On Live Server

Hi all, just deployed my laravel 5.5 app on a live server, however none of the links will route like they are supposed to. When you click on any link, I get a 404 error. I tried several attempts at tweaking the .htaccess file in the public folder nothings changes.

Here is the original that came with the app that works fine on a local server

Options -MultiViews

RewriteEngine On


# Redirect Trailing Slashes If Not A Folder...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} (.+)/$
RewriteRule ^ %1 [L,R=301]

# Handle Front Controller...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php [L]

# Handle Authorization Header
RewriteCond %{HTTP:Authorization} .
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

And is the latest one I tried to get to work

Options -MultiViews

RewriteEngine On
RewriteBase /ota/public/

# Redirect Trailing Slashes...
RewriteRule ^(.*)/$ / [L,R=301]

# Handle Front Controller...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php [L]

Nothing seems to work. What am I doing wrong?

Dane

10 Oct
1 year ago

dane5890 started a new conversation Vue Data Component Not Showing In Laravel 5.5

Hi, working on building a vue component with a simple data to test binding on an input form, however, the changes don't show up. It also appears that none of the v events, for example v-model and v-on, doesn't appear to work neither. Below is vue template file...

Your Name

{{ name }}

export default {

data: {

name: ""

},

methods: {

onName: function() {

this.name = event.target.value;

}

}

}

Below is the content of my app.js file

/**

  • First we will load all of this project's JavaScript dependencies which
  • includes Vue and other libraries. It is a great starting point when
  • building robust, powerful web applications using Vue and Laravel. */

require('./bootstrap');

window.Vue = require('vue');

/**

  • Next, we will create a fresh Vue application instance and attach it to
  • the page. Then, you may begin adding components to this application
  • or customize the JavaScript scaffolding to fit your unique needs. */

Vue.component('example', require('./components/Example.vue')); Vue.component('marketing', require('./components/Marketing.vue'));

const app = new Vue({ el: '#app' });

const app2 = new Vue({ el: '#app2' });

on my blade page I merely put

dane5890 left a reply on Laravel 5.4 Mix Renders Blank Vue Js Component

After updating some scripts in package json and then reinstalling node modules and then running npm run dev to mix, I get this error now

ERROR Failed to compile with 4 errors 21:18:51

This dependency was not found:

  • /var/www/html/out-of-the-ashes/resources/assets/sass/app.scss in multi ./resources/assets/js/app.js ./resources/assets/sass/app.scss

To install it, you can run: npm install --save /var/www/html/out-of-the-ashes/resources/assets/sass/app.scss

These relative modules were not found:

  • ./components/Example.vue in ./resources/assets/js/app.js
  • ./components/Speaking.vue in ./resources/assets/js/app.js
  • ./components/Marketing.vue in ./resources/assets/js/app.js Asset Size Chunks Chunk Names /js/app.js 1.42 MB 0 [emitted] [big] /js/app mix-manifest.json 32 bytes [emitted] npm ERR! code ELIFECYCLE npm ERR! errno 2 npm ERR! @ dev: cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js npm ERR! Exit status 2 npm ERR! npm ERR! Failed at the @ dev script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in: npm ERR! /home/dane5890/.npm/_logs/2017-10-10T04_18_51_389Z-debug.log

Here are the contents of my package.json file

{ "private": true, "scripts": { "dev": "cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js", "watch": "cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --watch --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js", "watch-poll": "cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --watch --watch-poll --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js", "hot": "cross-env NODE_ENV=development node_modules/webpack-dev-server/bin/webpack-dev-server.js --inline --hot --config=node_modules/laravel-mix/setup/webpack.config.js", "production": "cross-env NODE_ENV=production node_modules/webpack/bin/webpack.js --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js" }, "dependencies": { "bootstrap-vue": "^0.16.1", "elasticsearch": "^12.1.3", "keen-ui": "^0.8.9", "material-ui-vue": "^0.1.4", "material-vue": "^0.1.2", "materialize-css": "^0.97.8", "timepiece-vue": "^0.0.6", "ts-loader": "^1.3.3", "underscore": "^1.8.3", "v-svg": "^1.0.0", "vee-validate": "^2.0.0-rc.9", "velocity-animate": "^1.4.0", "vue-awesome": "^2.1.0", "vue-carousel-3d": "^0.1.8", "vue-class-component": "^4.4.0", "vue-comps-waves": "^1.0.1", "vue-human-icons": "^1.4.0", "vue-icons": "^2.0.0", "vue-m-carousel": "1.0.7", "vue-material": "^0.6.3", "vue-material-icons": "^0.0.1", "vue-material-svg-icons": "^0.0.2", "vue-mdl": "^0.11.0", "vue-my-dropdown": "^1.0.1", "vue-octicon": "^2.1.0", "vue-popup": "^0.2.14", "vue-router": "^2.2.0", "vue-ss": "^0.1.1", "vue-strap": "^1.1.36", "vue-svg": "^1.0.1", "vue-videobg": "^1.0.1", "vuelidate": "^0.2.0", "vuex": "^2.1.1", "vum": "^0.1.1" }, "devDependencies": { "axios": "^0.15.3", "bootstrap-sass": "^3.3.7", "cross-env": "^3.2.3", "jquery": "^3.1.1", "laravel-mix": "^0.8.1", "lodash": "^4.17.4", "vue": "^2.1.10", "vue-overlay": "^2.0.0", "vuetify": "^0.11.1" } }

dane5890 left a reply on Laravel 5.4 Mix Renders Blank Vue Js Component

Hi deleted node folder, updated my node js and npm tried to run npm run dev and I get this

ERROR Failed to compile with 1 errors 21:10:31

This dependency was not found:

  • vue-easy-slider in ./~/babel-loader/lib?{"cacheDirectory":true,"presets":[["env",{"modules":false,"targets":{"browsers":["> 2%"],"uglify":true}}]]}!./~/vue-loader/lib/selector.js?type=script&index=0!./resources/assets/js/components/Speaking.vue

To install it, you can run: npm install --save vue-easy-slider Asset Size Chunks Chunk Names fonts/vendor/bootstrap-sass/bootstrap/glyphicons-halflings-regular.eot?f4769f9bdb7466be65088239c12046d1 20.1 kB [emitted] fonts/vendor/bootstrap-sass/bootstrap/glyphicons-halflings-regular.svg?89889688147bd7575d6327160d64e760 109 kB [emitted] fonts/vendor/bootstrap-sass/bootstrap/glyphicons-halflings-regular.ttf?e18bbf611f2a2e43afc071aa2f4e1512 45.4 kB [emitted] fonts/vendor/bootstrap-sass/bootstrap/glyphicons-halflings-regular.woff?fa2772327f55d8198301fdb8bcfc8158 23.4 kB [emitted] fonts/vendor/bootstrap-sass/bootstrap/glyphicons-halflings-regular.woff2?448c34a56d699c29117adc64c43affeb 18 kB [emitted] /js/app.js 1.45 MB 0 [emitted] [big] /js/app /css/app.css 681 kB 0 [emitted] [big] /js/app mix-manifest.json 66 bytes [emitted] npm ERR! code ELIFECYCLE npm ERR! errno 2 npm ERR! @ development: cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js npm ERR! Exit status 2 npm ERR! npm ERR! Failed at the @ development script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in: npm ERR! /home/dane5890/.npm/_logs/2017-10-10T04_10_31_811Z-debug.log npm ERR! code ELIFECYCLE npm ERR! errno 2 npm ERR! @ dev: npm run development npm ERR! Exit status 2 npm ERR! npm ERR! Failed at the @ dev script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in: npm ERR! /home/#/.npm/_logs/2017-10-10T04_10_31_869Z-debug.log

09 Oct
1 year ago

dane5890 left a reply on Laravel 5.4 Mix Renders Blank Vue Js Component

It mixes with no errors, and Example.Vue does not work. I'm using an external vue template under the components folder where Example.Vue is located.

I'm stumped

dane5890 started a new conversation Laravel 5.4 Mix Renders Blank Vue Js Component

Hi, I'm developing an app with Laravel 5.4. Whenever I create a Vue component and use mix to render the component, it show up blank on the page.

Below are the contents of webpack.mix.js file

const { mix } = require('laravel-mix');

/* |-------------------------------------------------------------------------- | Mix Asset Management |-------------------------------------------------------------------------- | | Mix provides a clean, fluent API for defining some Webpack build steps | for your Laravel application. By default, we are compiling the Sass | file for the application as well as bundling up all the JS files. | */

mix.js('resources/assets/js/app.js', 'public/js') .sass('resources/assets/sass/app.scss', 'public/css');

Thanks

06 Sep
1 year ago

dane5890 left a reply on Too Many Arguments (Php Artisan Make:migration Create)

Thank you all for your responses/. I got it to work. This is my first laravel project

dane5890 started a new conversation Too Many Arguments (Php Artisan Make:migration Create)

Hi I have a laravel 5.4 app and I'm trying to create a table to build a subscriber list. When I try to implement the command php artisan make:migration create_subscribers_table --table=subscribers –-create

I get the error below

[Symfony\Component\Console\Exception\RuntimeException] Too many arguments, expected arguments "command" "name",

I created a database subscriber on my local phpmyadmin. I'm stumped at this point. I'm running this app on Ubuntu 17.

Thanks for the help.

29 Apr
2 years ago

dane5890 started a new conversation Laravel 5.4 Routing And Anchor Tags

Hi, I'm new to laravel. I started a project with laravel 5.4 in development mode, and created some routes with blade views. I can access those manually with no problem, but when I try to apply an anchor tag with href={{url::to('')}}, either nothing will happen, or it won't fully pull in the new blade view. If I manually type in localhosy:8000/name-of-blade-view, then I can access the view.

I can't even access external pages like yahoo or google. Can anyone point out what I'm doing wrong? Below are my web routes.

Route::get('/', function () { return view('welcome'); });

Route::get('/books', function () { return view('books'); });

Route::get('/index-ie', function () { return view('index-ie'); });

Route::get('/about', function () { return view('about/about-splash'); });

Route::get('/about', function () { return view('about/about'); });

Route::get('/news', function () { return view('news/news'); });

Route::get('/news/broken-debut', function () { return view('news/broken-debut'); });

Route::get('/collections-splash', function () { return view('collections/collections-splash'); });

Route::get('/collections', function () { return view('collections/collections'); });

Route::get('/books/eternals/eternals-1', function () { return view('books/eternals/eternals-1'); });

Route::get('/books/bv/bv-1', function () { return view('books/bv/bv-1'); });

Route::get('/books/vampangel/va-1', function () { return view('books/vampangel/va-1'); });

Route::get('/books/cory/cory-1', function () { return view('books/cory/cory-1'); });

Route::get('/books/cory/cory-1-intro', function () { return view('books/cory/cory-1-intro'); });

02 Mar
2 years ago

dane5890 left a reply on How To Include External PHP File That Is Not A Blade View Page

I figured it out. Thanks again for the help!

dane5890 left a reply on How To Include External PHP File That Is Not A Blade View Page

I'm aware that Rootup is your project variable. My question is, where did you define the Rootup variable in your project? Was it on the blade.page itself or in the app folder with controller. That's my question.

Thanks again for your help, and yes I looked at the manual, but that manual mostly references classic php includes which are useless in Laravel %.4

dane5890 left a reply on How To Include External PHP File That Is Not A Blade View Page

Thanks, do I define ROOTUP and for that matter my custom function in the app controller file? Where exactly. I'm completely new at this.

dane5890 started a new conversation How To Include External PHP File That Is Not A Blade View Page

Hi, I'm new to Laravel. My project is based on version 5.4, but when I try to include an external php file that's not a blade view file, nothing works. The traditional <php include method is not accepted.

I've tried methods such as <?php include public_path() . and even app_path(), and those don't work. I'm confused. What am I doing wrong?

Dane