Wouter_Veen

Wouter_Veen

Member Since 3 Months Ago

Experience Points
190
Total
Experience

4,810 experience to go until the next level!

In case you were wondering, you earn Laracasts experience when you:

  • Complete a lesson — 100pts
  • Create a forum thread — 50pts
  • Reply to a thread — 10pts
  • Leave a reply that is liked — 50pts
  • Receive a "Best Reply" award — 500pts
Lessons Completed
0
Lessons
Completed
Best Reply Awards
0
Best Reply
Awards
  • start-engines Created with Sketch.

    Start Your Engines

    Earned once you have completed your first Laracasts lesson.

  • first-thousand Created with Sketch.

    First Thousand

    Earned once you have earned your first 1000 experience points.

  • 1-year Created with Sketch.

    One Year Member

    Earned when you have been with Laracasts for 1 year.

  • 2-years Created with Sketch.

    Two Year Member

    Earned when you have been with Laracasts for 2 years.

  • 3-years Created with Sketch.

    Three Year Member

    Earned when you have been with Laracasts for 3 years.

  • 4-years Created with Sketch.

    Four Year Member

    Earned when you have been with Laracasts for 4 years.

  • 5-years Created with Sketch.

    Five Year Member

    Earned when you have been with Laracasts for 5 years.

  • school-session Created with Sketch.

    School In Session

    Earned when at least one Laracasts series has been fully completed.

  • welcome-newcomer Created with Sketch.

    Welcome To The Community

    Earned after your first post on the Laracasts forum.

  • full-time-student Created with Sketch.

    Full Time Learner

    Earned once 100 Laracasts lessons have been completed.

  • pay-it-forward Created with Sketch.

    Pay It Forward

    Earned once you receive your first "Best Reply" award on the Laracasts forum.

  • subscriber-token Created with Sketch.

    Subscriber

    Earned if you are a paying Laracasts subscriber.

  • lifer-token Created with Sketch.

    Lifer

    Earned if you have a lifetime subscription to Laracasts.

  • lara-evanghelist Created with Sketch.

    Laracasts Evangelist

    Earned if you share a link to Laracasts on social media. Please email [email protected] with your username and post URL to be awarded this badge.

  • chatty-cathy Created with Sketch.

    Chatty Cathy

    Earned once you have achieved 500 forum replies.

  • lara-veteran Created with Sketch.

    Laracasts Veteran

    Earned once your experience points passes 100,000.

  • 10k-strong Created with Sketch.

    Ten Thousand Strong

    Earned once your experience points hits 10,000.

  • lara-master Created with Sketch.

    Laracasts Master

    Earned once 1000 Laracasts lessons have been completed.

  • laracasts-tutor Created with Sketch.

    Laracasts Tutor

    Earned once your "Best Reply" award count is 100 or more.

  • laracasts-sensei Created with Sketch.

    Laracasts Sensei

    Earned once your experience points passes 1 million.

  • top-50 Created with Sketch.

    Top 50

    Earned once your experience points ranks in the top 50 of all Laracasts users.

Level 1
190 XP
Aug
14
3 months ago
Activity icon

Replied to Blade Directive's Not Working

Hi @erixo , are you using the package htmlmin. In my case this was the problem, after deleting it every thing start working again.

Activity icon

Replied to Blade Directive's Not Working

Hi every one. Thank you all for you answers and replies. I have found the problem, it was in a package I use htmlmin after removing this package every thing used works like it should, and again, thanks for all the help.

Aug
13
3 months ago
Activity icon

Replied to Blade Directive's Not Working

@nakov I have indeed registered the ServiceProvider in the config\app.php. And I can see with x-debug that the custom directive is loaded.

Activity icon

Replied to Blade Directive's Not Working

@nakov Yes I did clear the cache like the Laravel documentation says to do. So unfortunately it's not in the cache.

Aug
12
3 months ago
Activity icon

Started a new Conversation Blade Directive's Not Working

I have upgraded my project from 5.7 to 5.8 and now mu custom directives don't work. So I got some custom Blade Directives for Ziggy. I have made these directive in a seperate ServiceProvider like so

    public function boot()
    {
        \Blade::directive('routes', function($group = null){
            return "<?php echo app('" . BladeRouteGenerator::class . "')->generate({$group}); ?>";
        });
    }

And in the blade.php file I call this like:

@routes()

But the blade just returnes this like plain text and not like the routes it should give. Nou I have tried this in a new project and there it works. In Laravel 5.7 it worked and now when i upgrade to 5.8 it stoped working.

And when I use standaard directives like:

@if(false)
    <h1>False</h1>
@else
    <h1>True</h1>
@endif

It wil print True like expected, so only the custom directives are not working.

Does somebody has the same issue or has a solution to this issue?

UPDATE So apparently the problem lies in a package I used htmlmin link of issue , after deleting this package everything is working like it should be.