NithApple

NithApple

Member Since 5 Months Ago

Experience Points
6,360
Total
Experience

3,640 experience to go until the next level!

In case you were wondering, you earn Laracasts experience when you:

  • Complete a lesson — 100pts
  • Create a forum thread — 50pts
  • Reply to a thread — 10pts
  • Leave a reply that is liked — 50pts
  • Receive a "Best Reply" award — 500pts
Lessons Completed
35
Lessons
Completed
Best Reply Awards
1
Best Reply
Awards
  • start your engines Created with Sketch.

    Start Your Engines

    Earned once you have completed your first Laracasts lesson.

  • first-thousand Created with Sketch.

    First Thousand

    Earned once you have earned your first 1000 experience points.

  • 1-year Created with Sketch.

    One Year Member

    Earned when you have been with Laracasts for 1 year.

  • 2-years Created with Sketch.

    Two Year Member

    Earned when you have been with Laracasts for 2 years.

  • 3-years Created with Sketch.

    Three Year Member

    Earned when you have been with Laracasts for 3 years.

  • 4-years Created with Sketch.

    Four Year Member

    Earned when you have been with Laracasts for 4 years.

  • 5-years Created with Sketch.

    Five Year Member

    Earned when you have been with Laracasts for 5 years.

  • school-in-session Created with Sketch.

    School In Session

    Earned when at least one Laracasts series has been fully completed.

  • welcome-newcomer Created with Sketch.

    Welcome To The Community

    Earned after your first post on the Laracasts forum.

  • full-time-student Created with Sketch.

    Full Time Learner

    Earned once 100 Laracasts lessons have been completed.

  • pay-it-forward Created with Sketch.

    Pay It Forward

    Earned once you receive your first "Best Reply" award on the Laracasts forum.

  • subscriber Created with Sketch.

    Subscriber

    Earned if you are a paying Laracasts subscriber.

  • lifer Created with Sketch.

    Lifer

    Earned if you have a lifetime subscription to Laracasts.

  • evangelist Created with Sketch.

    Laracasts Evangelist

    Earned if you share a link to Laracasts on social media. Please email [email protected] with your username and post URL to be awarded this badge.

  • chatty-cathy Created with Sketch.

    Chatty Cathy

    Earned once you have achieved 500 forum replies.

  • lara-veteran Created with Sketch.

    Laracasts Veteran

    Earned once your experience points passes 100,000.

  • 10k-strong Created with Sketch.

    Ten Thousand Strong

    Earned once your experience points hits 10,000.

  • lara-master Created with Sketch.

    Laracasts Master

    Earned once 1000 Laracasts lessons have been completed.

  • laracasts-tutor Created with Sketch.

    Laracasts Tutor

    Earned once your "Best Reply" award count is 100 or more.

  • laracasts-sensei Created with Sketch.

    Laracasts Sensei

    Earned once your experience points passes 1 million.

  • top-50 Created with Sketch.

    Top 50

    Earned once your experience points ranks in the top 50 of all Laracasts users.

Level 2
6,360 XP
Jul
09
23 hours ago
Activity icon

Replied to Simple API And How To Use It

you can go to routes folder then u will see api.php

Route::get('foo', function () { $users = \DB::table('users')->get(); return response(['message'=> $users]); });

whenever we work with API we don't have any interface if you want to test it you have to use Postman https://www.postman.com/

Jul
02
1 week ago
Activity icon

Started a new Conversation Push Database Mysql From Local To Heroku

I want to test with the project that I need to use multi db is possible to push database from our local to Heroku?

Jul
01
1 week ago
Activity icon

Replied to Remove Package From Node_modules

npm uninstall package_name --save you got a warning because you're using the new or old package

Activity icon

Replied to Create Database On Live Server (heroku)

thanks for the reply, but I really need to push 3 databases for my project what I should do?

Activity icon

Started a new Conversation Recommend Hosting Free For Laravel

I am just starting with backend and now I wanna testing my project to the server but I need to learn how to deploy the project for free first anyone please recommended hosting for free

Jun
30
1 week ago
Activity icon

Started a new Conversation Create Database On Live Server (heroku)

I work with the dynamic database I have a lot of databases and I wanna testing with hosting that free now I have found (Heroku) but when I use the command of laravel to create more database I got message say ( SQLSTATE[42501]: Insufficient privilege: 7 ERROR: permission denied to create database ) is possible or not if I wanna push my database to Heroku with data and I don't want to migrate it?

Jun
21
2 weeks ago
Activity icon

Replied to Create Virtual Host On MAC BOOK

thank you so much 😊

Jun
18
3 weeks ago
Activity icon

Started a new Conversation Create Virtual Host On MAC BOOK

I trying to create Virtual Host on mac but it not works I follow https://medium.com/@wilbo/adding-a-virtual-host-in-mamp-for-mac-a6c717cc0475 this link to create

please tell me how to create it or can past the link that you think it should work thanks

Activity icon

Replied to Recommended Package For Dynamic Tenancy In Laravel 6

thank you so much I will try this

Activity icon

Started a new Conversation Recommended Package For Dynamic Tenancy In Laravel 6

Now I found a package used for dynamic tenancy https://tenancyforlaravel.com/ but this package can't custom table name to another name that I want

Activity icon

Commented on MySQL 101

Navicat is my favorite tool for me

Jun
15
3 weeks ago
Activity icon

Replied to "message": "Token Could Not Be Parsed From The Request.",

sorry sir that i ask this question I got this error because I forgot the use content type to

Jun
13
3 weeks ago
Activity icon

Replied to "message": "Token Could Not Be Parsed From The Request.",

thank sir for reply could you show me how to send a request using Authorization in postman you just show me the example

Activity icon

Started a new Conversation "message": "Token Could Not Be Parsed From The Request.",

I am using JWT package version "tymon/jwt-auth": "^1.0.0-rc.5" for user auth and I have to override a little bit inside LoginController when I try to login by using postman I got message error as below

"message": "Token could not be parsed from the request.",

I can't find what is wrong at my code, anyone please help

Jun
11
4 weeks ago
Activity icon

Replied to Brew Install PHP 7.2 Instead Of 7.3

it works fine but when we restart terminal PHP version will back to version 7.3

Jun
04
1 month ago
Activity icon

Replied to Create Website Tutorial

thank you!

Activity icon

Started a new Conversation Create Website Tutorial

I would like to create a website tutorial for share knowledge related with coding to others but i don't know table in database should be have because i am no experience please anyone suggest me to create the table,

my requirements all users need to register first if they want to read or watch the videos on my website.

May
30
1 month ago
Activity icon

Replied to Composer Install Error

i am getting warning you can see as below after brew link [email protected]

Warning: [email protected] is keg-only and must be linked with --force

If you need to have this software first in your PATH instead consider running: echo 'export PATH="/usr/local/opt/[email protected]/bin:$PATH"' >> ~/.zshrc echo 'export PATH="/usr/local/opt/[email protected]/sbin:$PATH"' >> ~/.zshrc tsm168@tsm168s-MacBook-Pro api-workspace %

May
29
1 month ago
Activity icon

Replied to Composer Install Error

but i'm using php 7.3.11 and when i follow instructions but getting this error message : sudo: apt-get: command not found

Activity icon

Started a new Conversation Composer Install Error

tsm168@tsm168s-MacBook-Pro api-workspace % composer install Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1 - Installation request for phpoffice/phpspreadsheet 1.9.0 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - phpoffice/phpspreadsheet 1.9.0 requires ext-zip * -> the requested PHP extension zip is missing from your system. Problem 2 - maatwebsite/excel 3.1.0 requires phpoffice/phpspreadsheet ^1.4 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.1 requires phpoffice/phpspreadsheet ^1.4 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.10 requires phpoffice/phpspreadsheet ^1.6 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.11 requires phpoffice/phpspreadsheet ^1.6 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.12 requires phpoffice/phpspreadsheet ^1.6 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.13 requires phpoffice/phpspreadsheet ^1.6 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.14 requires phpoffice/phpspreadsheet ^1.6 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.15 requires phpoffice/phpspreadsheet ^1.6 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.16 requires phpoffice/phpspreadsheet ^1.6 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.17 requires phpoffice/phpspreadsheet ^1.6 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.2 requires phpoffice/phpspreadsheet ^1.4 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.3 requires phpoffice/phpspreadsheet ^1.4 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.4 requires phpoffice/phpspreadsheet ^1.4 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.5 requires phpoffice/phpspreadsheet ^1.4 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.6 requires phpoffice/phpspreadsheet ^1.4 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.7 requires phpoffice/phpspreadsheet ^1.6 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.8 requires phpoffice/phpspreadsheet ^1.6 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.9 requires phpoffice/phpspreadsheet ^1.6 -> satisfiable by phpoffice/phpspreadsheet[1.9.0]. - maatwebsite/excel 3.1.19 requires phpoffice/phpspreadsheet ^1.10 -> satisfiable by phpoffice/phpspreadsheet[1.10.0, 1.10.1, 1.11.0, 1.12.0] but these conflict with your requirements or minimum-stability. - maatwebsite/excel 3.1.18 requires phpoffice/phpspreadsheet ^1.10 -> satisfiable by phpoffice/phpspreadsheet[1.10.0, 1.10.1, 1.11.0, 1.12.0] but these conflict with your requirements or minimum-stability. - phpoffice/phpspreadsheet 1.9.0 requires ext-zip * -> the requested PHP extension zip is missing from your system. - Installation request for maatwebsite/excel ^3.1.0 -> satisfiable by maatwebsite/excel[3.1.0, 3.1.1, 3.1.10, 3.1.11, 3.1.12, 3.1.13, 3.1.14, 3.1.15, 3.1.16, 3.1.17, 3.1.18, 3.1.19, 3.1.2, 3.1.3, 3.1.4, 3.1.5, 3.1.6, 3.1.7, 3.1.8, 3.1.9].

May
27
1 month ago
Activity icon

Replied to Composer Is Not Working?

make sure go to inside laravel project

Activity icon

Started a new Conversation Undefined Type 'Route'. After Installed PHP Intelephense Extension On Vs Code

I'm using VsCode IDE for writing Laravel and I want to auto-import class on that IDE I have import PHP Intelephense extension that it can make me easy to import but It has the errors at routes file how to fix this?

May
25
1 month ago
Activity icon

Awarded Best Reply on Cannot Logout Using Passport Authentication

if you want to logout, just remove the token from your users table

if (Auth::check()) { Auth::user()->AauthAcessToken()->delete(); }

May
24
1 month ago
Activity icon

Replied to Cannot Logout Using Passport Authentication

if you want to logout, just remove the token from your users table

if (Auth::check()) { Auth::user()->AauthAcessToken()->delete(); }

Activity icon

Replied to Getting Warning When Composer Update Or Composer Install

thanks for reply but I can't upgrade currently I am using Laravel version 6 so if you have any solution to fix this please help

May
23
1 month ago
Activity icon

Started a new Conversation Getting Warning When Composer Update Or Composer Install

I get the errors when I'm using the command composer install or composer update, it's still working fine but I want to know why I get this warning? I just want to avoid this help, you can see the warning as below

Package jakub-onderka/php-console-color is abandoned, you should avoid using it. Use php-parallel-lint/php-console-color instead. Package jakub-onderka/php-console-highlighter is abandoned, you should avoid using it. Use php-parallel-lint/php-console-highlighter instead. Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested. Package zendframework/zend-diactoros is abandoned, you should avoid using it. Use laminas/laminas-diactoros instead.

Activity icon

Replied to How To Build Laravel Production And Encrypt Code

so thank you that provides me a good ideas

May
22
1 month ago
Activity icon

Replied to How To Build Laravel Production And Encrypt Code

can I connect with you because I really happy when I know you and i have a lot of questions want to ask you

Activity icon

Replied to Database Access In Middleware Laravel 6

I'm using this https://tenancyforlaravel.com/ package to dynamic the database by domain name so when we allow the domain name to access our system we need to add one by one so I don't want to do like this because domain name we already have in the database, but my problem can't retrieve the domain name from the database because the file that allows domain name to access extend from middleware so that's why I ask you how to retrieve data in inside middleware

Activity icon

Replied to How To Build Laravel Production And Encrypt Code

thanks for the reply I still wondering for example when I build angular project that angular is the front end I'm using ng build --prod I will get folder dist and inside that folder has the file that already compresses and in laravel we can build like angular or not?

Activity icon

Replied to How To Build Laravel Production And Encrypt Code

thanks for reply so now I want to build my project could you tell me how to build production sorry I'm beginners with laravel

May
21
1 month ago
Activity icon

Started a new Conversation How To Build Laravel Production And Encrypt Code

Currently, I'm using Laravel version 6 and I'm new with Laravel never build production before and I would like to encrypt code also because I don't want to someone understand my code after build

Activity icon

Started a new Conversation Database Access In Middleware Laravel 6

I would like to retrieve data from the database inside the middleware because I need to verify the token of which domain that can access to my system

May
19
1 month ago
Activity icon

Started a new Conversation Slance/tenancy Don't Need Tenancy Route

currently, I'm using slance/tenancy package for the dynamic database by the domain name but when I have a new route I need to add to api.php and tenant.php also. it possible or not if I use only inside api.php if it is possible please tell me the solution how to do that thanks.

Activity icon

Awarded Best Reply on Fruitcake / Laravel-cors

resolved

Activity icon

Replied to Fruitcake / Laravel-cors

resolved

Activity icon

Started a new Conversation Fruitcake / Laravel-cors

I'm using laravel for API and angular for front-end I already added fruitcake / laravel-cors but still got the error what can i do?

May
13
1 month ago
Activity icon

Started a new Conversation Possibility Use Laravel\socialite With API For Request From Angular?

I tried much time to search about using laravel\socialite package for login with Facebook and Google and just create the route for API and request from the front end but no someone implements with this if have someone ever implement with this please help

May
11
1 month ago
Activity icon

Replied to Login With Facebook Using "socialite" In API

I can to it in Laravel web but when I try to do this on API I'm still not clear so if you ever implement with this please help Thanks

Activity icon

Started a new Conversation Login With Facebook Using "socialite" In API

I'm using laravel version 6 and i want to use login with Facebook and google but i need to use it on API can tell me step by step to do this

May
04
2 months ago
Activity icon

Replied to Laravel 7 NOT Having Error CORS ?

I'm not sure but before I got this error too else you can try php artisan cache:clear

Activity icon

Replied to Laravel 7 NOT Having Error CORS ?

you can go to the bootstrap folder and then remove all file inside cache folder after that type commmand php artisan cache:clear

Apr
30
2 months ago
Activity icon

Started a new Conversation Stancl/tenancy Custom Database Name

I'm using laravel version 6 and also using stancl/tenancy package for dynamic database, but now I have some problem when I type this command "php artisan tenants:create -d my-domain1.com name=my-domain-1 plan=free [email protected] othes=test" to create a new database I got database name like this "ecommerce_db_af0a82cc-aa3f-48dc-8ded-3b70c4ba833b" so I want to custom database name by my own i try to read the documentation of that package but can't understand

Activity icon

Replied to Stancl/tenancy Front-end Can't Request

but I already solved my problems just allow domain name inside the middleware

Activity icon

Replied to Stancl/tenancy Front-end Can't Request

no, I don't, I don't know who are click on button best answer

Apr
29
2 months ago
Activity icon

Awarded Best Reply on Stancl/tenancy Front-end Can't Request

do you have another solution that we don't need to use the package?

Activity icon

Replied to Stancl/tenancy Front-end Can't Request

do you have another solution that we don't need to use the package?

Activity icon

Replied to Stancl/tenancy Front-end Can't Request

thanks for reply I'm using subdomains, the main domain it works fine not work the only subdomains

Activity icon

Started a new Conversation Stancl/tenancy Front-end Can't Request

I'm using laravel version 6 for API and my front-end is Angular, and also I have installed stancl/tenancy package for dynamic database by the domain name,it works fine when i test in Postman but it does not work when front end request and my error you can see below.

Access to XMLHttpRequest at 'http://my-domain1.com/categories?order_by=asc&order_col=ordering' from origin 'http://localhost:4200' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.