Mikejs

Experience

610

0 Best Reply Awards

  • Member Since 3 Months Ago
  • 0 Lessons Completed
  • 0 Favorites

19th August, 2017

Mikejs started a new conversation Sending Gifts Not Working - User Id Not Getting Sent • 1 month ago

Hi I hope someone can help I have a gifts plugin which is not including the userid in the request and therefore fails to work

this is my js code the request body viewed in the console shows

to_user=&gift_id=18&msg= as you can see no userid is being sent for to_user if I add

to_user=532&gift_id=18&msg= the gift is sent as expected

if( false ){ $('#gift-modal').show(); }

$('.giftimage').on('click',function(){

$('.giftimage').removeClass('activegift');

$(this).addClass('activegift');

})

$('#send_gift').on('click',function(){

var gift = $(this).parent().parent().find('.giftimage.activegift');

var gift_price =gift.data('price');

var gift_id =gift.data('giftid');

var msg='';


            data={to_user: $('#userid_gift').val() ,  gift_id:gift_id , msg:msg};


                $.ajax({
                              type: "POST",
                              url: "https://www.asiansocialdate.com/send_gift",
                              data: data,
                              success: function(data){
                                    
                                   toastr.success(data.message);
                                   
                                   window.location.reload();                                        
                                    
                              },
                              error: function(XMLHttpRequest, textStatus, errorThrown) {
                                    toastr.error("Some Error");
                              }
                              
               });

})

$('#giftmodal').on('click',function(){
    $('#userid_gift').val('532');   -- this is the correct userid 
    
    $('.gift_header').text("Send Gift");
})

The gifts are loaded into a modal window any suggestions on how I can fix this

27th July, 2017

Mikejs started a new conversation Manual Upgrade From 5.1 - 5.4 Packge Dependancy Problems Omnipay/paypal • 1 month ago

Hi I decided to manually upgrade my 5.1 app to 5.4 I have installed a fresh copy of Laravel 5.4 I have installed the various packages from my old app so I have the base to start copying over the code to the new framework, all the other packages has installed without a problem

When I try to install the omnipay/paypal package I get the following


D:\xampp\htdocs>composer require omnipay/paypal
Using version ^2.6 for omnipay/paypal
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install omnipay/paypal v2.6.3
    - Conclusion: don't install omnipay/paypal v2.6.2
    - Conclusion: don't install omnipay/paypal v2.6.1
    - Conclusion: remove symfony/event-dispatcher v3.3.5
    - Conclusion: don't install symfony/event-dispatcher v3.3.5
    - omnipay/common 2.4.0 requires guzzle/guzzle ~3.9 -> satisfiable by guzzle/guzzle[v3.9.0, v3.9.1, v3.9.2, v3.9.3].
    - omnipay/common 2.5.2 requires guzzle/guzzle ~3.9 -> satisfiable by guzzle/guzzle[v3.9.0, v3.9.1, v3.9.2, v3.9.3].
    - omnipay/common v2.3.4 requires guzzle/guzzle ~3.9 -> satisfiable by guzzle/guzzle[v3.9.0, v3.9.1, v3.9.2, v3.9.3].
    - omnipay/common v2.4.1 requires guzzle/guzzle ~3.9 -> satisfiable by guzzle/guzzle[v3.9.0, v3.9.1, v3.9.2, v3.9.3].
    - omnipay/common v2.5.0 requires guzzle/guzzle ~3.9 -> satisfiable by guzzle/guzzle[v3.9.0, v3.9.1, v3.9.2, v3.9.3].
    - omnipay/common v2.5.1 requires guzzle/guzzle ~3.9 -> satisfiable by guzzle/guzzle[v3.9.0, v3.9.1, v3.9.2, v3.9.3].
    - guzzle/guzzle v3.9.0 requires symfony/event-dispatcher ~2.1 -> satisfiable by symfony/event-dispatcher[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.25, v2.7.26, v2.7.27, v2.7.28, v2.7.29, v2.7.3, v2.7.30, v2.7.31, v2.7.32, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
    - guzzle/guzzle v3.9.1 requires symfony/event-dispatcher ~2.1 -> satisfiable by symfony/event-dispatcher[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.25, v2.7.26, v2.7.27, v2.7.28, v2.7.29, v2.7.3, v2.7.30, v2.7.31, v2.7.32, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
    - guzzle/guzzle v3.9.2 requires symfony/event-dispatcher ~2.1 -> satisfiable by symfony/event-dispatcher[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.25, v2.7.26, v2.7.27, v2.7.28, v2.7.29, v2.7.3, v2.7.30, v2.7.31, v2.7.32, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
    - guzzle/guzzle v3.9.3 requires symfony/event-dispatcher ~2.1 -> satisfiable by symfony/event-dispatcher[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.25, v2.7.26, v2.7.27, v2.7.28, v2.7.29, v2.7.3, v2.7.30, v2.7.31, v2.7.32, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
    - Can only install one of: symfony/event-dispatcher[v2.8.0, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.1, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.10, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.11, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.12, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.13, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.14, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.15, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.16, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.17, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.18, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.19, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.2, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.20, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.21, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.22, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.23, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.24, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.25, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.3, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.4, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.5, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.6, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.7, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.8, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.8.9, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.1.0, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.1.1, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.1.10, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.1.11, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.1.12, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.1.13, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.1.2, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.1.3, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.1.4, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.1.5, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.1.6, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.1.7, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.1.8, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.1.9, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.2.0, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.2.1, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.2.10, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.2.11, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.2.2, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.2.3, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.2.4, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.2.5, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.2.6, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.2.7, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.2.8, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.2.9, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.0, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.1, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.10, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.11, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.12, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.13, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.14, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.15, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.16, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.17, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.18, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.19, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.2, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.20, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.21, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.22, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.23, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.24, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.25, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.26, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.27, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.28, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.29, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.3, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.30, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.31, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.32, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.33, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.34, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.35, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.36, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.37, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.38, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.39, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.4, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.40, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.41, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.42, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.5, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.6, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.7, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.8, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.3.9, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.4.0, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.4.1, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.4.10, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.4.2, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.4.3, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.4.4, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.4.5, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.4.6, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.4.7, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.4.8, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.4.9, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.5.0, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.5.1, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.5.10, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.5.11, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.5.12, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.5.2, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.5.3, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.5.4, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.5.5, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.5.6, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.5.7, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.5.8, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.5.9, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.6.0, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.6.1, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.6.10, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.6.11, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.6.12, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.6.13, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.6.2, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.6.3, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.6.4, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.6.5, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.6.6, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.6.7, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.6.8, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.6.9, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.0, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.1, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.10, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.11, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.12, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.13, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.14, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.15, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.16, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.17, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.18, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.19, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.2, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.20, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.21, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.22, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.23, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.24, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.25, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.26, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.27, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.28, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.29, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.3, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.30, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.31, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.32, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.4, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.5, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.6, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.7, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.8, v3.3.5].
    - Can only install one of: symfony/event-dispatcher[v2.7.9, v3.3.5].
    - Conclusion: don't install symfony/http-foundation v3.3.5|install omnipay/common 2.4.0|install omnipay/common 2.5.2|install omnipay/common v2.3.4|install omnipay/common v2.4.1|install omnipay/common v2.5.0|install omnipay/common v2.5.1
    - Conclusion: don't install omnipay/paypal v2.6.3|remove symfony/http-foundation v3.3.5|install omnipay/common 2.4.0|install omnipay/common 2.5.2|install omnipay/common v2.3.4|install omnipay/common v2.4.1|install omnipay/common v2.5.0|install omnipay/common v2.5.1
    - Conclusion: don't install omnipay/paypal v2.6.3|don't install symfony/http-foundation v3.3.5|install omnipay/common 2.4.0|install omnipay/common 2.5.2|install omnipay/common v2.3.4|install omnipay/common v2.4.1|install omnipay/common v2.5.0|install omnipay/common v2.5.1
    - Conclusion: don't install omnipay/paypal v2.6.3|remove symfony/http-foundation v3.3.5|install omnipay/common 2.4.0|install omnipay/common 2.5.2|install omnipay/common v2.3.4|install omnipay/common v2.4.1|install omnipay/common v2.5.0|install omnipay/common v2.5.1
    - Conclusion: don't install omnipay/paypal v2.6.3|don't install symfony/http-foundation v3.3.5|install omnipay/common 2.4.0|install omnipay/common 2.5.2|install omnipay/common v2.3.4|install omnipay/common v2.4.1|install omnipay/common v2.5.0|install omnipay/common v2.5.1
    - Conclusion: don't install omnipay/paypal v2.6.2|remove symfony/http-foundation v3.3.5|install omnipay/common 2.4.0|install omnipay/common 2.5.2|install omnipay/common v2.3.4|install omnipay/common v2.4.1|install omnipay/common v2.5.0|install omnipay/common v2.5.1
    - Conclusion: don't install omnipay/paypal v2.6.2|don't install symfony/http-foundation v3.3.5|install omnipay/common 2.4.0|install omnipay/common 2.5.2|install omnipay/common v2.3.4|install omnipay/common v2.4.1|install omnipay/common v2.5.0|install omnipay/common v2.5.1
    - Conclusion: don't install omnipay/paypal v2.6.2|remove symfony/http-foundation v3.3.5|install omnipay/common 2.4.0|install omnipay/common 2.5.2|install omnipay/common v2.3.4|install omnipay/common v2.4.1|install omnipay/common v2.5.0|install omnipay/common v2.5.1
    - Conclusion: don't install omnipay/paypal v2.6.2|don't install symfony/http-foundation v3.3.5|install omnipay/common 2.4.0|install omnipay/common 2.5.2|install omnipay/common v2.3.4|install omnipay/common v2.4.1|install omnipay/common v2.5.0|install omnipay/common v2.5.1
    - Conclusion: don't install omnipay/paypal v2.6.1|remove symfony/http-foundation v3.3.5|install omnipay/common 2.4.0|install omnipay/common 2.5.2|install omnipay/common v2.3.4|install omnipay/common v2.4.1|install omnipay/common v2.5.0|install omnipay/common v2.5.1
    - Conclusion: don't install omnipay/paypal v2.6.1|don't install symfony/http-foundation v3.3.5|install omnipay/common 2.4.0|install omnipay/common 2.5.2|install omnipay/common v2.3.4|install omnipay/common v2.4.1|install omnipay/common v2.5.0|install omnipay/common v2.5.1
    - Installation request for symfony/event-dispatcher (locked at v3.3.5) -> satisfiable by symfony/event-dispatcher[v3.3.5].
    - Conclusion: don't install omnipay/paypal v2.6.1|remove symfony/http-foundation v3.3.5|install omnipay/common 2.4.0|install omnipay/common 2.5.2|install omnipay/common v2.3.4|install omnipay/common v2.4.1|install omnipay/common v2.5.0|install omnipay/common v2.5.1
    - Conclusion: don't install omnipay/paypal v2.6.1|don't install symfony/http-foundation v3.3.5|install omnipay/common 2.4.0|install omnipay/common 2.5.2|install omnipay/common v2.3.4|install omnipay/common v2.4.1|install omnipay/common v2.5.0|install omnipay/common v2.5.1
    - Installation request for omnipay/paypal ^2.6 -> satisfiable by omnipay/paypal[v2.6.0, v2.6.1, v2.6.2, v2.6.3].
    - Conclusion: remove symfony/http-foundation v3.3.5|install omnipay/common 2.4.0|install omnipay/common 2.5.2|install omnipay/common v2.3.4|install omnipay/common v2.4.1|install omnipay/common v2.5.0|install omnipay/common v2.5.1
    - omnipay/paypal v2.6.0 requires omnipay/common ~2.0 -> satisfiable by omnipay/common[2.3.2, 2.4.0, 2.5.2, v2.0.0, v2.1.0, v2.2.0, v2.3.0, v2.3.1, v2.3.3, v2.3.4, v2.4.1, v2.5.0, v2.5.1].
    - omnipay/common 2.3.2 requires symfony/http-foundation ~2.1 -> satisfiable by symfony/http-foundation[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.25, v2.7.26, v2.7.27, v2.7.28, v2.7.29, v2.7.3, v2.7.30, v2.7.31, v2.7.32, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
    - omnipay/common v2.0.0 requires symfony/http-foundation ~2.1 -> satisfiable by symfony/http-foundation[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.25, v2.7.26, v2.7.27, v2.7.28, v2.7.29, v2.7.3, v2.7.30, v2.7.31, v2.7.32, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
    - omnipay/common v2.1.0 requires symfony/http-foundation ~2.1 -> satisfiable by symfony/http-foundation[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.25, v2.7.26, v2.7.27, v2.7.28, v2.7.29, v2.7.3, v2.7.30, v2.7.31, v2.7.32, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
    - omnipay/common v2.2.0 requires symfony/http-foundation ~2.1 -> satisfiable by symfony/http-foundation[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.25, v2.7.26, v2.7.27, v2.7.28, v2.7.29, v2.7.3, v2.7.30, v2.7.31, v2.7.32, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
    - omnipay/common v2.3.0 requires symfony/http-foundation ~2.1 -> satisfiable by symfony/http-foundation[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.25, v2.7.26, v2.7.27, v2.7.28, v2.7.29, v2.7.3, v2.7.30, v2.7.31, v2.7.32, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
    - omnipay/common v2.3.1 requires symfony/http-foundation ~2.1 -> satisfiable by symfony/http-foundation[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.25, v2.7.26, v2.7.27, v2.7.28, v2.7.29, v2.7.3, v2.7.30, v2.7.31, v2.7.32, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
    - omnipay/common v2.3.3 requires symfony/http-foundation ~2.1 -> satisfiable by symfony/http-foundation[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.25, v2.7.26, v2.7.27, v2.7.28, v2.7.29, v2.7.3, v2.7.30, v2.7.31, v2.7.32, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
    - Can only install one of: symfony/http-foundation[v2.1.0, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.1.1, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.1.10, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.1.11, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.1.12, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.1.13, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.1.2, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.1.3, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.1.4, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.1.5, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.1.6, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.1.7, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.1.8, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.1.9, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.2.0, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.2.1, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.2.10, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.2.11, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.2.2, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.2.3, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.2.4, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.2.5, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.2.6, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.2.7, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.2.8, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.2.9, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.0, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.1, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.10, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.11, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.12, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.13, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.14, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.15, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.16, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.17, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.18, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.19, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.2, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.20, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.21, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.22, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.23, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.24, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.25, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.26, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.27, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.28, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.29, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.3, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.30, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.31, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.32, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.33, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.34, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.35, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.36, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.37, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.38, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.39, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.4, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.40, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.41, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.42, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.5, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.6, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.7, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.8, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.3.9, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.4.0, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.4.1, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.4.10, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.4.2, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.4.3, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.4.4, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.4.5, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.4.6, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.4.7, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.4.8, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.4.9, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.5.0, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.5.1, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.5.10, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.5.11, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.5.12, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.5.2, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.5.3, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.5.4, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.5.5, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.5.6, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.5.7, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.5.8, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.5.9, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.6.0, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.6.1, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.6.10, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.6.11, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.6.12, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.6.13, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.6.2, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.6.3, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.6.4, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.6.5, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.6.6, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.6.7, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.6.8, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.6.9, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.0, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.1, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.10, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.11, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.12, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.13, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.14, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.15, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.16, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.17, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.18, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.19, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.2, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.20, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.21, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.22, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.23, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.24, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.25, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.26, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.27, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.28, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.29, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.3, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.30, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.31, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.32, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.4, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.5, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.6, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.7, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.8, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.7.9, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.0, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.1, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.10, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.11, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.12, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.13, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.14, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.15, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.16, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.17, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.18, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.19, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.2, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.20, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.21, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.22, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.23, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.24, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.25, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.3, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.4, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.5, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.6, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.7, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.8, v3.3.5].
    - Can only install one of: symfony/http-foundation[v2.8.9, v3.3.5].
    - Installation request for symfony/http-foundation (locked at v3.3.5) -> satisfiable by symfony/http-foundation[v3.3.5].

is the omnipay/paypal not compatible with Laravel 5.4 is there another paypal package I could use instead

thanks

Mike

26th July, 2017

Mikejs left a reply on Trying To Get User Referals To Work • 1 month ago

Ok so some progress now its failing with

''' FatalThrowableError in StoreReferralCode.php line 26: Call to undefined method Illuminate\Http\Response::cookie() '''

this is the store referral code

'''

Mikejs left a reply on Trying To Get User Referals To Work • 1 month ago

So I see the request is getting blocked 500 internal server error

send @ jquery.min.js:4 ajax @ jquery.min.js:4 (anonymous) @ register?ref=b892eb42-71d1-11e7-99d8-00163cadd928:301 dispatch @ jquery.min.js:3 r.handle @ jquery.min.js:3

it looks like the anonymous request is not allowed anyway of getting this to work

24th July, 2017

Mikejs started a new conversation Trying To Get User Referals To Work • 1 month ago

LAravel 5.1.46 - VPS CentOS - Apache - Nginx

Hi I have followed this tutorial Adding Referral for adding a referral system to my app

The referral code is working and I can see the program has been added to the DB, however when I try testing the referral is not getting logged.

I have cleared the cookies and cache from the browser prior to using the referral link, I use the link to go to the registration page and register a new account.

I login tot he new account and then check in the other browser to see if the number of referrals have been updated - it stays at 0

This is the referral code for creating the link between the referrer and new user

23rd July, 2017

Mikejs left a reply on Trying To Update From 5.1.46 - 5.2.0 • 2 months ago

Thanks for the reply I have progressed a little now I get

Your requirements could not be resolved to an installable set of packages.

Problem 1 - Can only install one of: laravel/framework[5.2.x-dev, 5.1.x-dev]. - Can only install one of: laravel/framework[5.2.x-dev, 5.1.x-dev]. - Can only install one of: laravel/framework[5.2.x-dev, 5.1.x-dev]. - Installation request for laravel/framework 5.2.x-dev -> satisfiable by laravel/framework[5.2.x-dev]. - Installation request for laravel/framework (locked at 5.1.x-dev, required as 5.2.x-dev) -> satisfiable by laravel/framework[5.1.x-dev]. Installation failed, reverting ./composer.json to its original content.

Mikejs started a new conversation Trying To Update From 5.1.46 - 5.2.0 • 2 months ago

Hi I am trying to update to 5.4 - my current project is 5.1.46 - when I try update to 5.2.0 I get the following

[code] Problem 1 - laravelcollective/html v5.1.10 requires illuminate/support 5.1.* -> satisfiable by laravel/framework[v5.1.46], illuminate/support[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.41, v5.1.6, v5.1.8]. - laravelcollective/html v5.1.10 requires illuminate/support 5.1.* -> satisfiable by laravel/framework[v5.1.46], illuminate/support[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.41, v5.1.6, v5.1.8]. - laravelcollective/html v5.1.10 requires illuminate/support 5.1.* -> satisfiable by laravel/framework[v5.1.46], illuminate/support[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.41, v5.1.6, v5.1.8]. - Can only install one of: laravel/framework[v5.2.0, v5.1.46]. - don't install illuminate/support v5.1.1|don't install laravel/framework v5.2.0 - don't install illuminate/support v5.1.13|don't install laravel/framework v5.2.0 - don't install illuminate/support v5.1.16|don't install laravel/framework v5.2.0 - don't install illuminate/support v5.1.2|don't install laravel/framework v5.2.0 - don't install illuminate/support v5.1.20|don't install laravel/framework v5.2.0 - don't install illuminate/support v5.1.22|don't install laravel/framework v5.2.0 - don't install illuminate/support v5.1.25|don't install laravel/framework v5.2.0 - don't install illuminate/support v5.1.28|don't install laravel/framework v5.2.0 - don't install illuminate/support v5.1.30|don't install laravel/framework v5.2.0 - don't install illuminate/support v5.1.31|don't install laravel/framework v5.2.0 - don't install illuminate/support v5.1.41|don't install laravel/framework v5.2.0 - don't install illuminate/support v5.1.6|don't install laravel/framework v5.2.0 - don't install illuminate/support v5.1.8|don't install laravel/framework v5.2.0 - Installation request for laravel/framework 5.2.0 -> satisfiable by laravel/framework[v5.2.0]. - Installation request for laravelcollective/html (locked at v5.1.10, required as 5.1.*) -> satisfiable by laravelcollective/html[v5.1.10]. [/code]

This is my composer file

[code] { "name": "laravel/laravel", "description": "The Laravel Framework.", "keywords": ["framework", "laravel"], "license": "MIT", "type": "project", "require": { "php": ">=5.5.9", "laravel/framework": "5.2.0", "socialiteproviders/instagram": "", "socialiteproviders/vkontakte": "", "socialiteproviders/generators": "", "laravel/socialite": "^2.0", "laravelcollective/html": "5.1.", "maatwebsite/excel": "~2.1.0", "stripe/stripe-php": "3.", "ext-curl": "", "guzzlehttp/guzzle": "5.3.0", "oriceon/oauth-5-laravel": "dev-master", "google/apiclient": "^2.0.0@RC", "omnipay/paypal": "~2.0", "facebook/graph-sdk": "~5.0@dev", "intervention/image": "dev-master", "barryvdh/laravel-debugbar": "^2.2", "geoip2/geoip2": "~2.0" }, "require-dev": { "fzaninotto/faker": "~1.4", "mockery/mockery": "0.9.*", "phpunit/phpunit": "~4.0", "phpspec/phpspec": "~2.1" }, "autoload": { "classmap": [ "vendor/google/apiclient/src/Google", "database" ], "psr-4": { "App\": "app/" } }, "autoload-dev": { "classmap": [ "tests/TestCase.php" ] }, "scripts": { "post-install-cmd": [ "php artisan clear-compiled", "php artisan optimize" ], "pre-update-cmd": [ "php artisan clear-compiled" ], "post-update-cmd": [ "php artisan optimize" ], "post-root-package-install": [ "php -r "copy('.env.example', '.env');"" ], "post-create-project-cmd": [ "php artisan key:generate" ] }, "config": { "preferred-install": "dist" } }

[/code]

20th July, 2017

Mikejs started a new conversation Email Authentication Fails • 2 months ago

I am using the datingframework after a test registration I get an email with an activation link

the activate account.blade only has this line of code

[code] Click to activate[/code]

I get an error message You don't have permission to access /sample/activate/1/Y[email protected]gmail.com

it looks like the authenticate email was not finished it also looks like the link is getting switched I have found several tutorials on email auth but they all use a different method in my user table I have a status column in the admin area it shows as unverified, most of the tutorials refer to adding a new column for authenticated I presume this is the same thing.

any idea how I can fix this or does anyone know of a service that can recode an app bugfix update to latest version etc

thanks

Mike

17th July, 2017

Mikejs left a reply on Contact Form Error View [contact.contact] Not Found • 2 months ago

Thanks for the info I already have

"illuminate/html":"5.0.*",

and added

Illuminate\Html\HtmlServiceProvider::class,

'Form'=> Illuminate\Html\FormFacade\Form::class, 'Html'=> Illuminate\Html\HtmlFacade\Html::class,

I created the form using standard html markup and it works now

Mikejs left a reply on Contact Form Error View [contact.contact] Not Found • 2 months ago

Why is this so difficult I thought the point of a framework was to make life simple

I have redone the steps in the guide and now I get

Class 'Illuminate\Html\FormFacade\Form' not found

in my form I am using

{!! Form::open(array('route' => 'contact_store', 'class' => 'form')) !!}

I have installed "illuminate/html":"5.0.*",

and added

    Illuminate\Html\HtmlServiceProvider::class,

and

    'Form'=> Illuminate\Html\FormFacade\Form::class,
    'Html'=> Illuminate\Html\HtmlFacade\Html::class, 

to my app.php

At the moment Laravel = WTF why is everything so difficult

Mikejs left a reply on Contact Form Error View [contact.contact] Not Found • 2 months ago

Hi thanks for the reply its not my guide :-) I just want to add a contact form to my app

the guide states you can use /contact to load the form which it does - the problem is after the form is submitted I get a debug error

the message is received - any step by step guides that work with Laravel 5.1 to add a contact form to an existing project?

thanks

15th July, 2017

Mikejs started a new conversation Contact Form Error View [contact.contact] Not Found • 2 months ago

Hi I have followed this guide http://www.easylaravelbook.com/blog/2015/02/09/creating-a-contact-form-in-laravel-5-using-the-form-request-feature/ to create a simple contact form for my website the form worked for sending but then got stuck with error View [contact.contact] not found.

The form loaded I filled out the info and sent a test message which arrived in my mailbox but instead of a message it got stuck on the error above?

My routes

Route::get('contact', ['as' => 'contact', 'uses' => '[email protected]']); Route::post('contact', ['as' => 'contact_store', 'uses' => '[email protected]']);

My contact.blade.php

{!! Form::open(array('route' => 'contact_store', 'class' => 'form')) !!}

{!! Form::label('Your Name') !!} {!! Form::text('name', null, array('required', 'class'=>'form-control', 'placeholder'=>'Your name')) !!} {!! Form::label('Your E-mail Address') !!} {!! Form::text('email', null, array('required', 'class'=>'form-control', 'placeholder'=>'Your e-mail address')) !!} {!! Form::label('Your Message') !!} {!! Form::textarea('message', null, array('required', 'class'=>'form-control', 'placeholder'=>'Your message')) !!} {!! Form::submit('Contact Us!', array('class'=>'btn btn-primary')) !!} {!! Form::close() !!}

My AboutController

namespace App\Http\Controllers;

use Illuminate\Http\Request;

use App\Http\Requests; use App\Http\Controllers\Controller;

class AboutController extends Controller { public function create() { return view('contact.contact'); }

public function store(ContactFormRequest $request)
{
    \Mail::send('emails.contact',
    array(
        'name' => $request->get('name'),
        'email' => $request->get('email'),
        'user_message' => $request->get('message')
    ), function($message)
{
    $message->from('email');
    $message->to('[email protected]', 'Admin')->subject('Contact');
});
     return \Redirect::route('contact')->with('message', 'Thanks for contacting us!');
}

}

and my contact.blade.php

You received a message from TODOParrot.com:

Name: {{ $name }}

{{ $email }}

{{ $user_message }}

I already had "laravelcollective/html": "5.1.*", in my composer.json and I added the following to app.php

Providers

    Illuminate\View\ViewServiceProvider::class,
    Illuminate\Html\HtmlServiceProvider::class,

Aliases

    'Form'=> Illuminate\Html\FormFacade::class, 
    'Html'=> Illuminate\Html\HtmlFacade::class,

If I create a folder called contact and add my contact.blade.php I get this error

Undefined variable: name (View:

Not sure what's wrong in the guide it uses \Mail::send('contact.contact', but the contact.blade.php is created under the emails folder?

17th June, 2017

Mikejs started a new conversation WebsocketChat • 3 months ago

Hi I am having trouble getting a user chat to work on the app I purchased I was told it need the PCNTL extension I am using cloudways to run a test but the chat is not working it uses SocketIO and Workerman I am hoping someone else is using this in their site and can help me get it setup

thanks

Mike

Mikejs started a new conversation WebsocketChat • 3 months ago

Hi I am struggling to get this chat script to work, the only info I have been told is my server requires PCNTL Extension to run the chat script I was hoping someone is using a similar chat app in their site and can offer some help to get it running. It uses PHPSocket_IO the server.php uses

use Workerman\Worker; use Workerman\Lib\Timer; use PHPSocketIO\SocketIO; use App\Repositories\WebsocketChatRepository as chatRepo; use App\Models\ChatContact; use App\Models\Notifications; use App\Models\User; use App\Components\Plugin;

Mikejs started a new conversation Updating My App • 3 months ago

Hi when I run the composer update I get 27 updates available should I still run the update?

composer update

php artisan clear-compiled Loading composer repositories with package information Updating dependencies (including require-dev) Package operations: 0 installs, 27 updates, 0 removals

  • Updating symfony/var-dumper (v2.7.26 => v2.7.29): Downloading (100%)
  • Updating symfony/translation (v2.7.26 => v2.7.29): Downloading (100%)
  • Updating symfony/routing (v2.7.26 => v2.7.29): Downloading (100%)
  • Updating symfony/process (v2.7.26 => v2.7.29): Downloading (100%)
  • Updating symfony/polyfill-mbstring (v1.3.0 => v1.4.0): Downloading (100%)
  • Updating symfony/http-foundation (v2.7.26 => v2.7.29): Downloading (100%)
  • Updating symfony/event-dispatcher (v2.8.19 => v2.8.22): Downloading (100%)
  • Updating symfony/debug (v2.7.26 => v2.7.29): Downloading (100%)
  • Updating symfony/http-kernel (v2.7.26 => v2.7.29): Downloading (100%)
  • Updating symfony/finder (v2.7.26 => v2.7.29): Downloading (100%)
  • Updating symfony/dom-crawler (v2.7.26 => v2.7.29): Downloading (100%)
  • Updating symfony/css-selector (v2.8.19 => v2.8.22): Downloading (100%)
  • Updating symfony/console (v2.7.26 => v2.7.29): Downloading (100%)
  • Updating swiftmailer/swiftmailer (v5.4.6 => v5.4.8): Downloading (100%)
  • Updating league/flysystem (1.0.37 => 1.0.40): Downloading (100%)
  • Updating symfony/polyfill-util (v1.3.0 => v1.4.0): Downloading (100%)
  • Updating symfony/polyfill-php56 (v1.3.0 => v1.4.0): Downloading (100%)
  • Updating laravelcollective/html (v5.1.9 => v5.1.10): Downloading (100%)
  • Updating facebook/php-sdk-v4 (5.4.x-dev 26bc142 => 5.5.x-dev 93d7dc8): The package has modified files: M tests/FacebookBatchRequestTest.php M tests/FacebookBatchResponseTest.php M tests/FacebookRequestTest.php M tests/FacebookResponseTest.php M tests/GraphNodes/CollectionTest.php

if I say yes to modifying the facebook test scripts are they going to break my app? after it finishes it will suggest I change to use facebook/graph-sdk as the facebook/php-sdk-v5.4 is abandoned

I purchased this app and I am new to the Laravel framework I was going to try and upgrade to the new version but I think there is to much to modify the whole app is about 160 mb

thanks

Mike

9th June, 2017

Mikejs started a new conversation Trying To Install Laravel App On Hosting • 3 months ago

Hi I hope someone can help me I have an application that uses the Laravel framework I have uploaded the main app to a folder on my host named script I have set my www.domain.com folder to use public as its root

so I have a folder structure like this:

/ script public

I have set the file paths in my index,php file to:

require DIR.'/../script/bootstrap/autoload.php'; $app = require_once DIR.'/../script/bootstrap/app.php';

When I run the script installer it asks me to set the script/public folder to be writable so it looks like the installer is not seeing the correct path.

In my installerRepository.php I have these lines

//this function creates all required directories for theme in public folder
public function createDir($theme)
{
    if(!Storage::has('/public/themes/'. $theme))
        Storage::makeDirectory('/public/themes/'. $theme);
}

//copy assets contents to themes/{theme} folder
public function copyAssets($theme)
{
    $src  = base_path()."/resources/views/themes/{$theme}/assets";
    $dest = public_path()."/themes/{$theme}";

Which I presume will copy the contents for the themes to the public folder so the site will display correctly

is there a way to set the new path for the installer to use

thanks

Mike

Edit Your Profile
Update

Want to change your profile photo? We pull from gravatar.com.